Monday, April 22, 2013

XenServer 6.1, Dell OpenManage and SNMP

I finally updated our productive environment to XenServer 6.1. The upgrade went without a hitch, but there are still many issues with Windows VMs and the XenTools. In the end completely removing the XenTools and reinstalling them did the trick.

Anyway, this post is about Dell OpenManage and SNMP. I've found a spot-on post in the Citrix forums here - thanks Josh Phillips. Read on for the details.


Those are the exact steps:
  1. Follow the steps in the Dell OM 7.2 Linux repository:
    wget -q -O - http://linux.dell.com/repo/hardware/latest/bootstrap.cgi | bash
    yum install srvadmin-all
  2. The latter command complanis about missing dependencies (e.g. libxslt.so.1 ) so let's enable the CentOS-Base repo to fix it. Edit /etc/yum.repos.d/CentOS-Base.repo and change [Base] to "enabled=1".
  3. yum install srvadmin-allThis will now proceed.
  4. Firewall adjustments - I'm always extra extra careful when messing with iptables rules. It's just too easy to make a typo and lock yourself out. I'm much more comfortable by making those adjustements in the system-config GUI.
    Note: The default putty console window size is too small to show the whole dialog, at least on my XenServers. So I had to resize it before running the command.
    Also if window borders look weird, make sure to change Putty Translation options to UTF-8.

    1. Run "system-config-securitylevel-tui"
    2. Go to "Customize"
    3. Go to the text box "Other Ports" in "Allow incoming". Append the following strings. Please note the comma!
      1. ,1311:tcp
        This is to allow access to the OMSA web interface
      2. ,161:udp
        This will allow incoming SNMP requests
  5. XenServer snmpd is quite restrictive by default. In our environment it's ok to respond to all requests, read-only. We do this by adding the line "view systemview included .1" after the line "view systemview included snmp" in /etc/snmp/snmpd.conf.
  6. Now restart snmpd by running:
    service snmpd restart
  7. And let's start Dell OMSA by running:
    /opt/dell/srvadmin/sbin/srvadmin-services.sh start
Make sure you're able to log in to the web interface on https://<server>:1311. Also your XenServer host should now respond to any SNMP queries.
The whole process takes less than 10 minutes, depending on your internet connection. About 200MBs need to be downloaded. The XenServer does not need to be rebooted!

5 comments:

Thanhd said...

Hi

I have followed your guide and is stuck at step 3 after running yum install srvadmin-all I get the below error:

Downloading Packages:
http://linux.dell.com/repo/hardware/latest/platform_independent/rh50/srvadmin-i386/srvadmin-jre-7.2.0-4.460.1.el5.i386.rpm: [Errno 12] Timeout:
Trying other mirror.


Error Downloading Packages:
srvadmin-jre-7.2.0-4.460.1.el5.i386: failure: srvadmin-i386/srvadmin-jre-7.2.0-4.460.1.el5.i386.rpm from dell-omsa-indep: [Errno 256] No more mirrors to try.

Thanhd said...

I've worked out that the error is due to a timeout. For some reason it it taking ages for the dell sever to respond when serving that file.

By increasing the yum timeout error to 300 I was able to get it going and working.

Steps
edit the /etc/yum.conf file

Add to the end the below line
timeout=300

re run yum install srvadmin-all again

It will take some time but will eventually download all the files and install successfully.

T Carter said...

Thanks - I was looking for these firewall rules.
Even after applying these changes, restarting the iptables and OMSA services I still can't connect to the OMSA web interface though. Just get a 404 error. Any ideas?

Anonymous said...

Thanks so much for these tricks !
Others blogs and forums were wrong and, furthermore, DELL states that tcp 1311 cannot be used on XenServer 6.1 and 5986 must be used through an other station with OpenManage installed ! Your solution was simple and works at the first attempt.

Laurent Marandet
Paris - France

Anonymous said...

Thanks much! Exactly what I needed, and dead on instructions.

Kevin